Convertible top problems and center console latch

It was a really nice morning and I had some time so I messed with the Jeepster a bit today.  I decided to look into the first two bows on the convertible top.  As you can see above they are no longer attached to the top.   The staples you see poking through are part of the problem.  Those are in a folded over flap in the top and are supposed to be firmly held in some sort of soft material in the top of the bow.  Obviously that is not happening.

Continue reading “Convertible top problems and center console latch”

Top wiring


Time to wire up the top motor.  This is where I think I want to put them.  This up under the dash on the left side above the kick panel.  The main circuit breaker is just over on the right with all those red wires going into it.  That reinforcing bar running across there looks like a fine place to mount some relays.


The thing is I would rather not drill any holes to mound this.  So I dug around in my scrap metal and found this bit of sheet steel.  I think it is part of an old floppy drive of all things.  I measured out a strip about two inches wide.


The idea is to make a hook that clamps to the top of that reinforcing bar.  To give it some spring I mounted a long screwdriver in vice and bent the strip around it.


After some bending and cutting I ended up with this.  I test fit it and marked the length so screws would not interfere with the structure of the car.  I marked the holes and drilled them.


Two sheet metal screws and the mounting is done.


I am putting the wiring diagram in here so the kids can play at home.


The first two wires are the wires that will run from the coils of the relay (86) to the switch.  These will route power to the up or down relay depending on which way the switch is pulled.  Here are the spade connectors that will connect to the switch.  I only had one insulated connector.  I will put shrink tube over the other one.


Notice the relay sockets are marked down and up.  Next I need to hook up the leads for battery power.  The two yellow wires tie to the normally open contact of the relays (87).  The yellow wires will get power from the circuit breaker via the red wire with the inline fuse.  Here I have the wires stripped and twisted together.

img_20160927_185637  img_20160927_185736

I soldered the wires.  I used that pair of forceps to keep the shrink tube from getting too hot.  Then I put the shrink tube in place and got it too hot 🙂


The other end of the power wire gets a ring terminal to tie to the circuit breaker.


Next are the ground wires.  The black wires are the coil grounds (85) and the red wires are the normally closed contacts on the relay (87a).   Those contacts will provide the grounds for the motor.


I soldered all these wires to a foot-long 14 gauge wire.  Eventually that wire will go to some handy ground under the dash.  The problem is I don’t have any shrink tube the right size to insulate this joint.  I will have to get some.


The two blue wires will connect the normally open contacts (87) to the existing power leads going back to the pump.  These make spade connectors will  attach to the connectors that used to connect to the switch.


Here is the end result.  I taped up the wire bundles and as soon as I get some more shrink tube I will install and test this.  I am pretty happy with it.

Ripping into the top

Actually that is probably a poor choice of title.  But I did decide to take a look at the convertible top.  Hopefully no ripping involved.


The pump does not run so I need to figure that out.  Here I pulled the power plug from the pump and put the voltmeter on it.  When I flip the switch I get 12V so the wiring is good.  Looks like that pump will have to come out for a closer look.  Fair warning:  this is not going to end well but I will document the process in case anyone else wants to tear into one of these.


For some dumb-ass reason the bolts holding the pump in are under the curve of the body of the pump so I can only get in there with a socket.  To getI to this last bolt I had to take the others out and rotate the pump.  More good news:  the system is full of brake fluid so now I am getting that all over the place.  Glad the paint is already crap.


Once I got the pump out I drained the reservoir.   This horror is what came out.  Brake fluid, dirt, and bits what appear to be vitally important seals.


The reservoir is held on with a long bolt with a weird triangular head.  I think that is intended to keep morons from mistaking the bolt for the fill plug but anyway it comes off with a normal 11/16″ wrench.   There was still more ugly in the reservoir.  Right here I decided that regardless of how the pump went I was going to pull the rams out and flush out the system.


Here is the pump and motor.  The two holes at the top are the intake ports for the pump.  It looks like there are check valves in there.  But those 5 bolts need to come out so we can see.


Sure enough, there are steel check valves and the gears of the pump.  The check valves redirect the output of the pump to either raise or lower the top depending on which way the pump runs.

vt_20160917_092654The gears slide out easily enough.  The inner gear has a groove near the yellow dot.  There is a matching hole in the motor shaft.  A small ball bearing goes in there to keep the inner gear from spinning on the motor shaft.  The really good news here is that there is not a lot of wear on the gears or the pump housing.  By the way the yellow dots are to help me put it back together the same way it came apart.


Here is the cavity with the ball bearing laying down in the bottom.  At this point I tried to rotate the motor.  It would not turn.  So now I get to dive into that.


Two long screws on the end of the motor hold the whole thing together.  They were a bit of a challenge.  Turns out steel screws in aluminum for 50 years get a little seized.  But I got them lose and pulled the end of the motor off.  Well this is not good….

vt_20160917_094543  vt_20160917_094539

This is hideous.  The bottom of the motor and the brush plate are both caked with old grease and crap.  By the way there is a ball bearing in the end of the motor shaft that I tried very hard to lose.  Time for some parts cleaning!

vt_20160917_102325  vt_20160917_102332

vt_20160917_102341  vt_20160917_102350

I carefully cleaned everything with kerosene then rubbing alcohol.  The motor does not look too bad.  All the coils have continuity.


Time to reassemble and see what I have.  I started with a clean piece of cardboard and laid out the parts.


I put the motor shaft into the motor.  I greased up the bushing and put the ball bearing in the end of the shaft.  Now comes the tricky part.  I have to get the brushes over the commutator.   It took about three tries.  Then more fooling around to get the long screws started in the holes in the pump body.


Moment of truth time!  I used this 12v battery from my old drill to test the motor.  It ran like a top!  Both directions worked.  Great!  Lets assemble the pump.


Here is the inner gear and the bearing that locks it onto the shaft.  I was not sure how to assemble this.  There may be a better way but this worked. I propped the motor up so the cavity for the bearing was pointed up and used a little grease to glue the bearing in.  It went right in.


I put the check balls in and lubricated everything with automatic transmission fluid. Which is what I will use to replace the brake fluid.


Boom!  Done.  At this point I was feeling pretty good about this.  But before I went any further I decided it was time to test the pump again.  I hooked up my battery and the pump tried to run then the wires got really hot.  I suspect a short in the motor coils.  In hindsight I might have screwed up using alcohol to clean out the motor.  If there was shellac in there insulating the coils I probably washed it off…


I took the pump cover back off just to make sure the motor is still free. It is.  So this is a fail.  I can probably get the motor rewound but I have been looking around and it seems like all convertible pumps are pretty much the same.  I may see about grabbing another pump from a junkyard.  The motor for a Chrysler Sebring or Ford Mustang should work just fine.  I am only worried about the sizes of the fittings on the pump.


Meanwhile I am going to pull the rams out and flush out the old fluid.  The remains of the interior trim will have to come out first.


The armrest bolts through the trim into the fender well.  It has not been off in a LONG time.  Both bolts broke off immediately.  One is just a bolt.  The other (on the right in the picture) screwed into a plate riveted on the plastic frame.  I will probably drill out the rivets and replace the plate with a bolt.


All the screws holding the panel on came out except these two in the floor.  They are rusted in there and will not turn.  Eventually I decided to just grind the screws off.  I got the Dremel tool out and went to work.  The kicker is that when I got the heads off the screws the panel plastic was shattered around them.  So I could have just left well enough alone.




This pile of fun was behind the panel.  I fished out the fragments of the panel and threw the rest away.


Now I can get at the cylinder.  In hindsight I probably could have done this with the panel in place.  I might do that on the other side.


Here is the cylinder and the fluid I got out of it.  The good news is the cylinder feels pretty good.  But I am out of time for today so the other side and cleaning the lines will have to wait.